Subscribe to this thread
Home - Cutting Edge / All posts - Manifold 9.0.180.7
adamw


10,447 post(s)
#06-Aug-23 14:38

9.0.180.7

manifold-9.0.180.7.zip

SHA256: 7370ef93e8321b7dd33991a06d46f882b976e9e082629888eed3594292914df6

manifold-viewer-9.0.180.7.zip

SHA256: 6969f730f6c0d578e59f6f188151c111c26ab4d53ca15e492661dd60881f3979

sql4arc-9.0.180.7.zip

SHA256: e29ba8220b3207b40143cc2b63d513953e9140daad291565bacc2585f6f36f65

adamw


10,447 post(s)
#06-Aug-23 14:39

Changes

Menus always use access keys for menu commands, even if access keys are hidden.

Automatically generated menu commands have access keys set to the first alphanumeric character in the command name. (This allows quickly selecting, eg, a field name in a long drop-down list by typing the first character. If there are multiple names that start with the same character, the system will move the cursor between them.)

(Fix) Parsing command names no longer interprets && as an access key ('&&' denotes a single '&' character, previously we were also erroneously interpreting that as an access key set to &).

The Info pane allows pinging the picked record in a map window. Pinging shows a sequence of circles with decreasing radius centered at the record, this helps locate the record on a big and / or busy screen.

The Info pane allows pinging the picked record in a layout window.

The Javascript control shows descriptions for locations.

The Javascript control shows descriptions for layers.

End of list.

Graeme

992 post(s)
#07-Aug-23 03:06

Thanks for the rapid response to this recent thread. Acknowledging wvayens note it "..works as advertised". Could well be operator error my end, but I'm not getting the expected result for a field named "Unique_ID" - moved to the top of the table order in Layers pane. When I click the Transform field picker drop-down and type "u", no fields beginning with a letter past "G" appear. See screenshots. Project started life as M8, saved as M9.

Attachments:
9_180_7 target table end schema.jpg
9_180_7 target table summary.jpg
9_180_7 Transform field picker.jpg
9_180_7 Transform U result.jpg

tjhb
10,096 post(s)
#07-Aug-23 05:26

I don't know Graeme, but two vague possibilities?

(1) Exactly how many fields does your table have? Maybe there is an internal search limit such as 127, 255, 16384(!). I think that's unlikely (or rather, it's likely to be so large that it never matters).

(2) Field type. Your Unique_ID is of type nvarchar. That means that it's not eligible for an Arithmetic operation (which is what you've pictured in the example). I think that's more likely, if I understand correctly.

Graeme

992 post(s)
#07-Aug-23 05:55

Thanks for the suggestion Tim, appreciated. 1000 fields approx.

The transform I want to apply is "concatenate", it won't appear as an option if a numeric field is in the field picker, I understand that. That's why being able to jump to it has thrown this issue. Virtually all the fields are numeric, a very limited number are text fields, but all are at the bottom of the schema.

Dimitri


7,454 post(s)
#07-Aug-23 07:02

There is something weird going on in your installation. Are you sure you are using 180.7? Are you sure it is a "clean" use of a portable build, that is, nothing unusual like copying only some of the files from the 180.7 unzipped hierarchy and then pasting them elsewhere?

Let's walk through this together step by step:

Here's what I did: Using 180.7 in Windows 11 (feel like I'm declaring namespaces when I write that... :-), I downloaded the ne_10m_admin_1_states_provinces shapefile from Natural Earth and imported that, to get a table with lots of fields, some of them numbers and some of them nvarchar text. I then opened the table and using Edit - Schema added a Unique_ID field of type nvarchar to the table.

With the focus on the opened table window, I opened the Transform pane.

As noted in the Transform Pane topic, using the Transform pane is a two-step process:

Step 2: At the top level you pick the layer you want to work with and the field within that layer you want to operate on. The pane then updates the list of possible templates to those which work with the data type of the field you picked. For example, it doesn't show "Arithmetic" if you picked a field that is nvarchar text.

Step 2: You pick the template you want to use and the Transform pane goes a level deeper into that template. Many of the templates also have Field boxes to allow picking some other field. The lists in those Field boxes will only show fields with data types that are the same as the initial field you picked. For example, if you picked a numeric field and then picked the Arithmetic template, the Field box in the Arithmetic template isn't going to list nvarchar text fields.

In all cases of the Field box, the lists in the Transform pane's Field box show fields in alphabetical order, not in the order they're displayed in the Layers pane.

I had no problem in step 1 clicking the Field box at the top level Transform pane and then pressing 'u' on the Keyboard. It instantly picked Unique_ID as the field, and then correctly refreshed the template list to show only templates that work with nvarchar text types.

If I clicked into any of those templates, such as 'Concatenate', the Field box in the template correctly showed only text type fields.

Likewise, if at the top level I chose any field that is a numeric type, the template list instantly refreshed to show only templates that work on numbers. If I chose one of them, like 'Arithmetic', the Field box in the template correctly showed only numeric types.

I tried to duplicate your "picker" screenshot. That shows a template list for numbers, so the AR... you had picked (or maybe it was the first in your list) has to be a numeric type. I picked a numeric type, mapcolor13, to get the numeric template list. I then clicked in the Field box again, pressed 'u' on the keyboard, and it instantly loaded Unique_ID.

I am puzzled by your "result" screenshot. I've not been able to create a Field picker list that includes the "Edit Advanced Favorites..." options shown at the bottom of the list in your screenshot. That's really weird. What version of Windows are you using?

I don't know what the limit is for the number of fields in a table. 1000 fields is a lot, but not all that big. The weirdness of seeing a list of commands in a drop down list that should be only fields looks like some sort of overrun error from very many fields in the list. I've reported that, just in case.

One last thing: a useful move for manual scrolling, is that if you start at the top of any of the dropdown Field lists, pressing the up arrow on the keyboard scrolls up through the list, rolling over to the bottom of the list. That's a quick way to manually pick any fields that appear at the very bottom of the list.

Graeme

992 post(s)
#07-Aug-23 07:31

Screenshot of "about" from a W10 machine, also using a W7 box side by side, same issue both machines. However I did install both from the same download. I have been cutting and pasting the extensions-dlls folder from the expired build folder, to the current build folder. See shots. I'll try and download the file again..

I appreciate the order is not that of the Layers pane, the previous shot of the schema shows the navchar field including Unique_ID at the bottom of the fields list, which is where I expect them to be, they're just not appearing.

AR is the first field and is a numeric field "AREA.."

The list of "command fields" I'm seeing instead, is really long.. bottom screen (arrow up) and then scrolled for the next screen..

Attachments:
Commands bottom of list.jpg
Commands next screen up.jpg
Graeme 180.7 installation.jpg
Graeme W10 about.jpg

Graeme

992 post(s)
#07-Aug-23 08:05

Downloaded a second version and overwrote the first in the cutting edge folder. No change.

Dimitri


7,454 post(s)
#07-Aug-23 08:48

The list of "command fields" I'm seeing instead, is really long.. bottom screen (arrow up) and then scrolled for the next screen..

That's definitely not right. I've tried this out on a Windows 10 machine and still for me everything is OK. But that's only with 124 fields in the table.

My guess (just a guess) is that this is an error either in Manifold or Microsoft's access key code. I wouldn't be surprised if somewhere deep inside Microsoft's (or Manifold's) code is an assumption that nobody will ever try to use more than 1024 access key entries in a list, and if you go past that you end up cycling through arrays allocated to things like menu command lists. Just a wild guess. :-)

It would be interesting to know the exact number of fields in your table (the info pane will tell you that). You could then make a copy of the table and then delete most of the records (to make it smaller and faster), and then in the Edit - Schema pane start deleting chunks of fields, trying out the Transform pane list with over a thousand fields, a thousand fields, 900 fields, and so on, to see if you hit a number of fields where the weird addition of commands in the list goes away.

Graeme

992 post(s)
#07-Aug-23 09:47

I'll try what you suggest and report back tomorrow. Thanks all for looking.

Graeme

992 post(s)
#08-Aug-23 00:41

At 1,000 fields, it behaves as expected - just table fields including Unique_ID and no "command icons".

The number of "command icons" reduced as I deleted fields from the starting point of 1,191, including a incremental step of 1 around the flagged 1,024.

Attachments:
180_7 1000 field info.jpg
180_7 1000 field result.jpg

Manifold User Community Use Agreement Copyright (C) 2007-2021 Manifold Software Limited. All rights reserved.