Subscribe to this thread
Home - General / All posts - french wms url
cassini101 post(s)
#16-Mar-23 08:18

Hello,

i have a wms url that normaly show different free french layers with Qgis (rasters)

https://geoservices.ign.fr/documentation/services/api-et-services-ogc/images-wms-ogc

Has anyone used this service before and could help me?

I would like to continue using my favorite software.

Thank's

Dimitri


7,400 post(s)
#16-Mar-23 09:18

The URL you quote is just a link to the information page on WMS servers operated by IGN. You need a URL to a specific server to be able to use a given WMS server as a data source.

You also need an access key. For example, the sample URLs on the site, such as

https://wxs.ign.fr/CLEF/geoportail/r/wms

you must replace CLEF (the key) with your personal key. That's covered in the page in the commentary "Le paramètre CLEF doit être remplacé par votre clé personnelle ou par celle définie dans une URL d'accès libre aux services web." ("The KEY parameter must be replaced by your personal key or by the one defined in an open access URL to web services.")

Presumably, if you're connecting to WMS using QGIS you have a personal key or a URL that is an "open access" URL to web services. You could use either one in Release 9. There's probably some info on the IGN site somewhere on how to get your personal CLEF.

cassini101 post(s)
#16-Mar-23 11:15

Thank you Dimitri,

yes, i requiested a Key and i have one.

I'm trying to establish a connection using this link which includes the key:

http://wxs.ign.fr/4y5fb8gurb72emkgejockqzv/geoportail/r/wms/

I get the following error (image1)

When I remove the S from httpS, I can see the list of available layers (image2)

Attachments:
Capture1.JPG
Capture2.JPG

Dimitri


7,400 post(s)
#16-Mar-23 13:07

I tried:

http://wxs.ign.fr/4y5fb8gurb72emkgejockqzv/geoportail/r/wms/

... and it worked fine.

I also tried (adding the s in https...)

https://wxs.ign.fr/4y5fb8gurb72emkgejockqzv/geoportail/r/wms/

... and that worked fine as well. I'm using build 9.0.179.4, the latest build.

cassini101 post(s)
#16-Mar-23 14:14

Dimitri,

I'm glad it works for you!

it may be a problem with M8 that I currently use.

Can you tell me how you do in manifold 9 which I also have but don't use?

I see that the import works differently in M9

Dimitri


7,400 post(s)
#16-Mar-23 15:14

Here's a topic that's a good start: Web Servers. There are other topics with specific examples of using WMS servers, like Example: Connect to a WMS Server for National Map Layers

You can download the free Viewer and try all that out in Viewer.

Lesternixon2 post(s)
#22-Mar-23 07:44

It is likely that you have a personal key or a "open access" URL to web services if you are using QGIS to connect to WMS. Version 9 allows you to use either one. How to obtain your own CLEF should be covered somewhere on the IGN website.

Manifold User Community Use Agreement Copyright (C) 2007-2021 Manifold Software Limited. All rights reserved.