Subscribe to this thread
Home - General / All posts - Cutting off tiff
sknox79 post(s)
#21-Feb-23 11:43

I have some odd behaviour with Manifold 9.0.179.2. I'm trying to import a GeoTiff, it imports fine in QGIS and FME and displays as expected. In Manifold the bottom of the file is cut off.

I've used a Raster Calculator to export as 1s to simplify the problem, and it is still happening. So I think what is occurring is that Manifold is not showing the first 19 stripes of height starting from the bottom, i.e. the bottom 19 rows are missing.

QGIS (via GDAL) reports the raster as having a Y dimension of 109 but there are only 90 visible Y stripes in Manifold.

I couldn't figure out what options I could tweak to change this, it seems quite fundamental.

I have attached the test file to test with.

Is anyone able to have a look?

Attachments:
Raster Manifold.png
Raster QGIS.png
Test_Raster.tif

Sloots

676 post(s)
#21-Feb-23 14:09

Same here, same version.


http://www.mppng.nl/manifold/pointlabeler

Dimitri


7,400 post(s)
#21-Feb-23 14:10

How was the tif created? What coordinate system does it use?

sknox79 post(s)
#21-Feb-23 14:18

Not totally sure how the original was created possibly in some CAD software, but that Tif was exported from QGIS through the Raster Calculator, in the Ordnance Survey National Grid (EPSG:27700) projection, so I assumed would be good to go, unless some odd metadata is sticking around somewhere between conversions?

I tried exporting from FME as well, that didn't seem to work either.

adamw


10,447 post(s)
#22-Feb-23 11:28

We'll check what is going on. Thanks a lot for the note and the file.

sknox79 post(s)
#23-Feb-23 14:51

New Build 9.0.179.3 seems to have fixed it!

danb

2,055 post(s)
#23-Feb-23 22:15

Wonderful. I just experienced a variation of this with a tif file this morning. Upgrade to the latest build and it has gone away. Thanks, sknox for posting about it and to tech for fixing it so swiftly.


Landsystems Ltd ... Know your land | www.landsystems.co.nz

Manifold User Community Use Agreement Copyright (C) 2007-2021 Manifold Software Limited. All rights reserved.