Subscribe to this thread
Home - General / All posts - Stamen Toner Lite tile server problems
radiowebst44 post(s)
#26-May-22 17:41

I have tested and tried many times but I cannot seem to get the Stamen Toner Lite image server to work in Manifold. Works fine in QGIS. Is there something different I should be doing in Manifold to make this work? I have another Stamen server that works for terrain data. Tried to just edit that one for the toner lite tiles and that didn't work either.

https://stamen-tiles-{s}.a.ssl.fastly.net/toner-lite/{z}/{x}/{y}{r}.png

Sloots

583 post(s)
#26-May-22 19:06

--SQL

CREATE DATASOURCE [Stamen Light] (

  PROPERTY 'Source' '{ "Source": "https:\\/\\/stamen-tiles-a.a.ssl.fastly.net\\/toner-lite\\/{zoom}\\/{x}\\/{y}@2x.png", "SourceAgent": "Mozilla\\/5.0 Manifold\\/9.0", "SourceCache": true, "SourceCacheTemp": true, "SourceTileSizeSingle": 512, "SourceUuid": "763bebec-99fb-4dae-91eb-ba5bd9905d49", "SourceZooms": [ 0, 20 ] }',

  PROPERTY 'Type' 'imageserver'

);

Run this in a command window.


http://www.mppng.nl/manifold/pointlabeler

radiowebst44 post(s)
#26-May-22 20:54

Worked like a charm! Thank you Sloots!

Can you explain why this didn't work by normal methods so that I may understand what I did wrong?

Sloots

583 post(s)
#26-May-22 22:15

My guess is that the {r} token is not taken care of and you must choose the right image size (512 instead of the default 256). Furthermore I believe that {z} must be changed to {zoom}.


http://www.mppng.nl/manifold/pointlabeler

adamw

10,011 post(s)
#01-Jun-22 13:56

Correct. The supported escape sequences like {x}, {y} or {zoom} are listed in Help, eg, in:

Start > Formats and Data Sources > Web Servers > Custom Servers

There's no {r}, it should be replaced with one of the allowed values, {z} should be {zoom}, and {s} should be either replaced with one of the allowed values or with {switch:...}.

Manifold User Community Use Agreement Copyright (C) 2007-2021 Manifold Software Limited. All rights reserved.